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Converting Arduino
Libraries to XOD

Whilst the XOD community is growing fast and new libraries are
being added all the time, you may find that certain hardware and
components do not yet have compatible XOD nodes. In this
case, there is almost always an Arduino IDE library that can be
used. Arduino libraries exist for a huge range of breakout boards
and other devices (see www.arduinolibraries.info). If you have a
little C++ experience, it is easy to incorporate these libraries into
XOD.

If you cannot find a XOD library for a device, you will need to look
for a class-based Arduino library. Manufacturers of breakout
boards typically provide C++ libraries for their devices. On the
product pages of companies such as Adafruit you will typically
find links to code repositories. For more unusual devices a web
search will often find libraries developed by hobbyists.

In this tutorial we will create a XOD library for the TSL2591 high
dynamic range digital light sensor. Adafruit produce breakout
boards for this sensor, available as either a solderable version or
with a STEMMA-QT socket (Qwiic-compatible, not Grove-
compatible). You can learn more about these breakout boards at
learn.adafruit.com/adafruit-tsl2591.

Adafruit’s code repository for their TSL2591 library is available
on github at www.github.com/adafruit/
Adafruit_TSL2591_Library. You should download this library
before starting this tutorial.

Please note that this tutorial assumes a basic knowledge of the
XOD IDE and C++. For our Beginner’s Guide to XOD see
www.www.biomaker.org/nocode-programming-for-biology-
handbook. For an excellent beginner’s short course in C++ see
www.codecademy.com/learn/learn-c-plus-plus.

Why Convert Arduino
Libraries?

Matt Wayland

Image Credits: Adafruit Industries CC

The Adafruit Industries TSL2591 Lux Sensor Breakout Boards.
Left to right: solderable and STEMMA-QT versions.
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Creating a XOD Library for the
TSL2591 Lux Sensor

Requirements
• Computer running MacOS, Windows or Linux with XOD software and USB driver installed (required)
• Adafruit TSL2591 library (required - download from www.github.com/adafruit/Adafruit_TSL2591_Library)
• Arduino IDE (for testing - download from www.arduino.cc/en/Main/Software)
• Arduino board and USB connector cable (for testing)
• Adafruit TSL2591 Lux Sensor and connectors (for testing)

When presented with a new device the first thing you should
do is check if it is already supported in XOD. There is a
searchable database of XOD libraries at www.xod.io/libs.

If you search for “light sensor” or “TSL2591” you will find that
a library already exists for this device (www.xod.io/libs/
wayland/tsl2591-light-sensor). However, for the purposes of
this tutorial, we will pretend that there is no library for the
TSL2591, and will instead convert the Adafruit C++ library for
use in XOD.

It is a good idea to test libraries you find using the Arduino
IDE. Well written libraries will include example sketches.
Reading through the sketches can help you to understand
how the methods in the library are used.

In this tutorial we will first test the Adafruit TSL2591 library in
the Arduino IDE, then ‘wrap’ this library for use in XOD. First
we will create a device node to represent the TSL2591 sensor,
then we will create action nodes to represent each of the
library’s member functions.

Connecting the TSL2591 Sensor to your Arduino
CONNECTING THE SOLDERABLE SENSOR TO A GROVE BOARD:
• Solder a six pin header set to the breakout board.
• Plug a 4-pin Grove-to-female connector into an I2C socket on the Grove board.
• Fit the male header pins on the breakout board into the female connector ends.
• Make sure the wire colours match the pins as follows: black to GND, red to Vin, white to SDA, yellow to SCL.

CONNECTING THE SOLDERABLE SENSOR TO A DIFFERENT ARDUINO BOARD:
• Solder a six pin header set to the breakout board.
• Use male-to-female wires to connect the pins on the breakout board to the header sockets on the board.
• Make sure the wires are connected as follows: GND to GND, Vin to VIN, SDA to SDA and SCL to SCL.

CONNECTING THE STEMMA-QT SENSOR:
• Use a SparkFun Qwiic Arduino board and connect with Qwiic cables.
• Or connect a SparkFun Qwiic shield to any other Arduino board and connect with Qwiic cables.

Matt Wayland
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INSTALL ARDUINO
IDE

1

Download the Arduino
IDE from the Arduino
website and install it
on your computer.

2

ADD LIBRARY TO IDE

From the ‘Tools’ menu select ‘Manage Libraries’. In the
Library Manager search for ‘tsl2591’. Select the most
recent version of the Adafruit TSL2591 Library and click
‘Install’. If you receive a prompt informing you that the
library is dependent on other libraries, click ‘Install all’.

UPLOAD

4

Click on the Upload
button. This is the
button on the top left
of the screen that
looks like an arrow.

RUN AN EXAMPLE SKETCH

3

Running an example sketch is a good way of checking
that the device is wired correctly to the Arduino board,
that the device is working, and that the library is working.
Open an example sketch by navigating to ‘File’ >
‘Examples’ > ‘Adafruit TSL2591 Library’ > ‘tsl2591’.

Testing the Arduino Library
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OPEN THE SERIAL
MONITOR

5

Once the program is
running, open the
serial monitor by
navigating to
‘Tools’ > ‘Serial
Monitor’.

TEST THE SKETCH

6

Make sure the speed is
set to 9600 baud. If
everything is working
data will be printed to
the serial monitor.

GO TO LIBRARY
GITHUB PAGE

7

In an internet browser,
navigate to www.
github.com/adafruit/
Adafruit_TSL2591_Lib
rary.

EXPLORE THE CODE

In the .h file find the public interface to the class. This
provides the class constructor and various member
functions. In XOD we will create a node for the device
and then an action node for each of the member
functions we want to use. Continue to browse the .cpp
and .h files to get a better idea of how the library works.

OPEN THE .H FILE

8

On Github you can
browser the .cpp and
.h files which contain
the code behind the
library. Click on the .h
file to open it.

9

Testing the Arduino Library

https://github.com/adafruit/Adafruit_TSL2591_Library
https://github.com/adafruit/Adafruit_TSL2591_Library
https://github.com/adafruit/Adafruit_TSL2591_Library
https://github.com/adafruit/Adafruit_TSL2591_Library
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Creating a TSL2591-Device Node

CREATE A NEW
PROJECT IN XOD

Open the XOD
software and start a
new project by
navigating to ‘File’ >
‘New Project…’.

10

RENAME YOUR
PATCH

11

Right-click on themain
patch in the Project
Browser and select
‘Rename’. Name the
patch ‘tsl2591-device’.

NOT-IMPLEMENTED-
IN-XOD NODE

12

Double click on the
patch and type ‘not-
implemented-in-xod’.
When the node appears,
click to add it to the
patch.

ADD AN OUTPUT-SELF NODE

13

Add an output-self node (xod/patch-nodes) in the same
way. Use the ‘Label’ box of the Inspector Pane to name it
‘DEV’. When you do this, you should notice two new
patches will automatically appear in the Project Browser:
input-tsl2591-device and output-tsl2591-device.

OPEN C++ CODE
EDITOR

Double-click on the
not-implemented-in-
xod node to open the
C++ code editor. You
will see some template
code in the editor.

14
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QUICK HELP

15

If you look at the Quick
Help pane there is a
C++ Cheatsheet listing
terminal nodes in the
patch. Here there is a
single output node.

ADD CODE

16

Delete the template code and add the prepared C++
code (download from the Biomaker website, or copy
from below).

Creating a TSL2591-Device Node

// Tell XOD where it can download the libraries:
#pragma XOD require "https://github.com/adafruit/
Adafruit_Sensor"
#pragma XOD require "https://github.com/adafruit/
Adafruit_TSL2591_Library"

//Include C++ libraries
#include <Adafruit_Sensor.h>
#include <Adafruit_TSL2591.h>

node {

meta {
// Define our custom type as a pointer on the

class instance.
using Type = Adafruit_TSL2591*;

}

C++ CODE FOR XOD TSL2591 DEVICE

// Create an object of class Adafruit_TSL2591
Adafruit_TSL2591 sensor = Adafruit_TSL2591();

void evaluate(Context ctx) {
// It should be evaluated only once on the first

(setup) transaction
if (!isSettingUp())
return;

// Try to initialize sensor
if (!sensor.begin()) {
raiseError(ctx);
return;

}
emitValue<output_DEV>(ctx, &sensor);

}
}
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UNDERSTAND EACH SECTION OF THE C++ CODE

A

B
C
D
E

F

Declare dependencies on the Arduino libraries so that XOD can automatically
download and install them.

Include the header files of the Arduino libraries.

Declare a custom type which describes the hardware module.

Create an instance of the custom type.

The evaluate function is called whenever the node requires updating. The
isSettingUp function returns true on the first transaction. It is used here to
ensure that the initialisation code runs once only. The begin function of the
Adafruit_TSL2591 class is called to initialise the sensor; if initialisation fails
an error is raised.

Finally an instance of type tsl2591-device is emitted via the patch terminal
node DEV. N.B. The custom type takes its name from the patch.

17

A

B

C

The TSL2591-Device C++ Code

D

E

F
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RETURN TO THE XOD
PATCH

18

You can return to the
XOD patch at ant time
by clicking the back
arrow in the top left of
the patch.

ACTION NODES

20

Now that we have a node to represent our device, we also need action nodes to initiate
actions or sequences from the Arduino library. In the header file, you can see that the
Adafruit_TSL2591 class has several member functions for configuring and reading data
from the sensor. We can make these functions available to XOD by wrapping them inside
nodes. As an example we’ll use the function to set the integration time (the length of time
the sensing element is collecting charge) of the device.

DESCRIBE YOUR NODE

19

Click on an empty space in the XOD patch, then use the
description box in the Inspector pane to write a short
description of your new node. You can also add
descriptions for each node within your patch by clicking
on them. This documentation is important as it will help
others to understand and use your libraries.

Documenting Your Device Node
and Introduction to Action Nodes
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THE INTEGRATION
TIME FUNCTION

21

This function is called
setTiming and takes
one argument:
tsl2591IntegrationTime
_t, which is an
enumerated type.

ADD NODES

24

Add the following nodes to your set-timing patch: input-
tsl2591-device (your patch), input-byte, input-pulse,
output-pulse, not-implemented-in-xod (xod/patch-nodes).
We will give them names, labels, and explain their
purposes in the following steps.

NAME THE PATCH

Following the
convention of starting
the names of action
nodes with a verb.
We’ll name this one
‘set-timing’.

Creating a Set-Timing Node

23

MAKE A NEW PATCH

22

Add a new patch to
XOD. Click the ‘Add
patch’ button in the
Project Browser or
select ‘File > New
Patch...’ in the menu.

INPUT-TSL2591-
DEVICE

25

Name this node ‘DEV’
with description ‘A
tsl2591-device’. This is
a tsl2591-device
created using our
tsl2591-device node.
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INPUT-PULSE

27

Name this node ‘UPD’
with description
‘Update’. Pulses
received by UPD will
trigger the action of
the node.

OUTPUT-PULSE

28

Name this ‘DONE’ with
description ‘Pulse on
completion’. This node
will output a pulse
when the integration
time has been set.

INPUT-BYTE

26

Name this node ‘TIME’ with description ‘Integration time
(milliseconds). Options: 100ms = 00h, 200ms = 01h,
300ms = 02h, 400ms = 03h, 500ms = 04h, 600ms = 05h’.
There’s no enum data type in XOD, so we’ll use a byte to
specify TIME and list the available integration times and
their byte values in the description.

NOT-IMPLEMENTED-
IN-XOD

29

We will use this node
to add C++ code
linking the XOD patch
to the Arduino library.

DEFAULT VALUES

30

We can set default
values for inputs. E.g.
set default integration
time to 300ms using
02h in the OUT field of
the TIME input.

Creating a Set-Timing Node
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The Set-Timing C++ Code

REPLACE THE TEMPLATE WITH CODE

31

Double-click on the not-implemented-in-xod node to open the C++ editor. Replace the
template with the code below (download from the Biomaker website or copy from below).
Read the comments for an explanation of each line.

node {
void evaluate(Context ctx) {
// The node responds only if there is an input pulse
if (!isInputDirty<input_UPD>(ctx))
return;

// Get a pointer to the `Adafruit_TSL2591` class
instance

auto sensor = getValue<input_DEV>(ctx);
sensor -> setTiming(getValue<input_TIME>(ctx));
emitValue<output_DONE>(ctx, 1);

}
}

C++ CODE FOR XOD SET-TIMING NODE

REPEAT FOR EACH
FUNCTION

32

Repeat the process for
each of the functions
in the Arduino library.
Use the wayland/
tsl2591-light-sensor
library as a reference.
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Creating a Quick-Start Node

CREATE A QUICK-START NODE

Let’s simplify use of our library by creating a single node with all the functionality a typical
user requires. For the TSL2591 sensor, we will assemble a lux meter.

33

A
B
C
D
E

The read-lux action node is triggered by a pulse to UPD and outputs total
luminosity (FULL), infrared luminosity (IR) and lux (LUX).

The inputs GAIN and TIME are used to set sensor gain and integration time
respectively.

The set-gain and set-timing action nodes are triggered on the initial boot and
also whenever the input values change.

The pulse-on-change nodes (xod/core) emit a pulse when the values of their
inputs change.

The get-gain and get-timing action nodes report the current sensor gain and
integration time respectively.

A

B

C

LUX-METER NODE

The finished lux-meter
node will look like this.

D

E

34
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Creating Example Patches and
Testing

MAKE AN EXAMPLE PATCH AND TEST YOUR PATCH

The lux-meter is our quick-start node which encompasses our device node, as
well as several action nodes, to take readings from the sensor.

A clock node is used to initiate a reading from the sensor every second.

Tweak nodes allow the user to adjust the gain and integration time at
runtime.

Watch nodes display the values output from the lux-meter.

35

Example patches demonstrate how to use your library and are also invaluable for testing.
This example patch shows how our newly-created lux-meter node can be used.

Once finished you should use your example patch to test your nodes. Use ‘Upload and
Debug’ to upload the patch to your Arduino, installing dependencies if you need to. Once
running you should see output to all watch nodes. Check whether the values being
reported by watch nodes are sensible, and try adjusting the gain and integration time.

A

B
C

D

A

B C

D
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Publishing Your Library

OPEN PROJECT
PREFERENCES

36

The first step to
publish your library is
to set the metadata.
Go to ‘Edit’ > ‘Project
Preferences…’ in the
menu bar.

SET METADATA:
NAME

37

Use this window to set
your library’s
metadata. Under
‘Name’ add a short, but
descriptive name (max
20 characters).

SET METADATA:
LICENCE

38

Under ‘Licence’ choose
an open source
software license (see
www.opensource.org/
licenses).

SET METADATA: DESCRIPTION

40

Briefly describe the purpose of the library. You may wish
to include a link to the underlying Arduino library and the
data sheet for the device. This information will be useful
for anyone wishing to use your library.

SET METADATA:
VERSION

39

Under ‘Version’ set the
version number using
Semver notation, i.e.
major.minor.patch.

https://opensource.org/licenses
https://opensource.org/licenses
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Publishing Your Library

UPDATE PROJECT
PREFERENCES

41

Click the ‘Update
Project Preferences’
button to save your
changes.

PUBLISH LIBRARY

42

When ready to publish,
go to ‘File’ > ‘Publish
Library…’. A window
will summarise the
metadata. Click
‘Publish’ to finalise.

XOD LIBRARY
DATABASE

43

Your library will now
appear in the XOD
database
(www.xod.io/libs),
available for other
users to download.

UPDATES

44

To update your library:
• Open the project.
• Make changes.
• Update metadata.
• Publish again.

Summary
The process of wrapping class-based Arduino libraries can be
summarised as follows:

1. Find Arduino library for device
2. Test Arduino library
3. Familiarise yourself with the class defined by the library
4. Start a new XOD project
5. Create a new device
6. Wrap class member functions in action nodes
7. Create a quick-start node
8. Create one or more example patches
9. Test library
10. Share library with XOD community

https://xod.io/libs/
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Useful Resources

Arduino Libraries
The following are good locations to search for relevant class-based Arduino libraries:
• Arduino: www.arduinolibraries.info
• Adafruit: www.adafruit.com
• Pololu: www.pololu.com
• Sparkfun: www.sparkfun.com
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XOD Resources
XOD DOCUMENTATION
XOD has good quality documentation for a range of projects available at www.xod.io/docs. The
following guides are particularly relevant for this tutorial:
• Wrapping class-based Arduino libraries: www.xod.io/docs/guide/wrapping-arduino-

libraries
• C++ API: www.xod.io/docs/reference/node-cpp-api
• Error handling: www.xod.io/docs/guide/errors
• Dealing with state: www.xod.io/docs/guide/cpp-state
• Dealing with time: www.xod.io/docs/guide/cpp-time

XOD FORUM
XOD has a friendly and helpful community. Don’t be afraid to ask for help on the forum at
www.forum.xod.io

XOD LIBRARIES
You can learn a lot from looking at existing libraries at www.xod.io/libs. However, you should be
aware that many use an older style of C++ syntax. See www.xod.io/docs/guide/migrating-to-
v035 for more details.
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